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The following changes have been made to DAT/EM products between Release 6.1 and Release 6.2. Please review these 
revisions made to the software and update your software to implement changes. 
 
As always, DAT/EM welcomes comments and suggestions from you, our clients, so please don’t hesitate to contact our 
support department at support@datem.com, or by calling in or faxing us with your requests. 
 
 
Operating Systems 
 
Release 6.2 is supported on Windows XP Professional, VISTA Ultimate and Windows 7 Ultimate or Professional 
operating systems. Testing no longer occurs for Windows 2000. If you have a question, please contact Support. 
 
CAD Versions 
 
Release 6.2 has interfaces to the following 32-bit and 64-bit CAD versions: 

• AutoCAD: Autodesk 2002, 2004, 2005, 2006, 2007, 2008, 2009, 2010 and 2011 products 
• ArcGIS: ArcMap 9.1, 9.2, 9.3 (service pack 1), 9.3.1(available service packs applied) 
• MicroStation: MicroStation V8 and V8 2004 Edition, XM, and V8i Series 1 are approved. DAT/EM cannot guarantee that the 

software will install correctly for V8i Series 2; please contact Support with questions about Select Series 2. 
 
 

Hardware Locks/Dongles 
 
Please install Microsoft Updates and Service Packs for your operating system before applying lock reset programs. Network licensing 
should have the same Sentinel driver version on both the server and the local computers running the software. 
 
 
SUMMIT EVOLUTION 

 

 
1. VERY IMPORTANT! The method of creating aerial frame and digital camera projects offers an easier method in 

version 6.2. 
 
All aerial digital and frame camera projects can now automatically rotate to display in left-right stereo and have a 
selected direction (usually north) as upright as possible in the SUMMIT EVOLUTION main view. 
 
Please read the following carefully: 
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• The New Project dialog now offers only one choice for aerial frame and digital cameras. In previous 
versions, the choices were Aerial Project, DMC, UltraCam, and DiMAC. These have been combined 
into a single Aerial – Frame & Digital Camera project. 

 
 

    
(Other New Project dialog changes are discussed in 2. below.) 

 
 

• The Aerial – Frame & Digital Camera project type has new settings: Automatically select best stereo 
view (ON/OFF) and North/South/East/West.  

 

 
 

The setting is Checked ON and set to North by default. 
 

 Ground coordinates must be available in order for these settings to activate. 
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 When ON and when ground coordinates are available, the software will automatically produce the 
best possible left-right stereo and display with the selected direction as upright as possible in the 
main view. Any two oriented overlapping images – even if they have top-bottom overlap – will be 
rotated to display in left-right stereo, and the selected direction will point as upright as possible 
while still maintaining good left-right stereo. 

 
 Previously, you might have applied a 180-degree rotation for every other flight strip. Now, you do 

not need to worry about flight strip directions. Leave all images at Rotation=0. 
 

 
In previous versions, some flight strips might be set to 180 degrees to make 

sure that the display of the “up” direction was the same between strips. 
This existing project will still work in version 6.2 with 

“Automatically select best stereo view” either ON or OFF. 
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For new projects made in version 6.2, all images may be set to Rotation=0. 

“Automatically select best stereo view” must be ON. Left-right stereo 
 and the “up” direction will be found automatically. 

 
 
 

 Previously, you might have applied a 90-degree (or 180 or 270) mount rotation setting to your 
digital camera file, and also a matching 90-degree (or 180 or 270) rotation to all the images in the 
Project Edit dialog. Now, you do not need to worry about the digital camera’s mount rotation. 
Leave all digital camera mount rotations at 0. Leave all image rotations at 0. (There are two 
exceptions. See Question D below.) 
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In previous versions, digital camera files and images might be set to 90/180/270 degrees to create 
left-right stereo and so that the display of the “up” direction was the same between flight strips. 

This existing project will work in version 6.2 with “Automatically select best stereo view” either ON or OFF. 
 
 

 
For new projects made in version 6.2, digital camera files may be set to Mount Rotation=0 and all the 

images may be set to Rotation=0. “Automatically select best stereo view” must be ON. 
Left-right stereo and the “up” direction will be found automatically. 

 
 

 All aerial frame and aerial digital camera projects created in previous versions of SUMMIT 
EVOLUTION with non-zero camera and/or image rotations will still work. You do not need to clear 
previously existing rotation settings. 

 
 The North/South/East/West setting determines which direction is most “up” on the screen. The 

selected direction will be positive in the first two quadrants of the screen. This may not point 
exactly “up”; but it will be as upright as possible while still maintaining left-right stereo. 
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 Question A: Why would I ever want the Automatically select best stereo view setting OFF? 
 

Answer 1: Turn the setting OFF to create projects for use with previous versions of 
SUMMIT EVOLUTION (version 6.1 and lower). When OFF, set up a project using the 
“traditional” method, that is, with rotation settings for digital camera mount direction and 
image rotation angles to match the flight direction and/or digital camera x axis mount 
direction. Instructions will remain in the Summit Evolution Operation Manual for the 
traditional settings. 
 
Answer 2: If you suspect that the camera was mounted incorrectly in the airplane so that 
it does not match its camera calibration report, turn OFF the setting to help troubleshoot 
the problem. 

 
 Question B: Do I need to turn OFF Automatically select best stereo view to use a project 

created by SUMMIT EVOLUTION version 6.1 or lower? 
 

Answer: No. You may use previously created projects and camera file just the way they 
are with Automatically select best stereo view ON. 

 
 Question C: I have an existing digital camera file that has 90CCW set for the camera’s x axis 

mount direction. I want to use Automatically select best stereo view ON. May I use this 
90CCW camera file to create new projects that have image rotations set to 0?  

 
Answer: No. Please make a copy of the camera file. Use the original camera file with old 
projects made by SUMMIT EVOLUTION 6.1 and lower. Edit the copy to have 0 x-axis mount 
rotation and apply the new camera file to any new projects that use 0 image rotations. 

 
 

 Question D: If I have Automatically select best stereo view ON, is there any time when my 
digital camera mount rotation will need to be different from the image rotation settings in the 
Project Edit dialog? 

 
Answer: Yes. There are two special cases when the angles will need to be different: 1) 
When the camera was mounted incorrectly in the airplane, so that it does not match the 
x-axis direction stated in its camera calibration report; 2) When the image files on disk 
have been incorrectly rotated, for example, if IMAGE CREATOR was accidentally set to 
Rotation=90 when it was not necessary. 
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2. There are changes to the New Project dialog choices: 
 

  
 

• The Aerial Project, DMC, UltraCam, and DiMAC project types have been combined into a single 
Aerial – Frame & Digital Camera project. 

 
• Satellites: Spot 5, … and PCI Models using Propack have been combined into the single PCI 

Models using Propack. These project types were effectively the same in previous versions. The 
only difference in previous versions was a PCI licensing issue that no longer applies. 

 
• The [Obsolete] Geomatica 10 project type has been removed. It is no longer supported. Please 

ask DAT/EM about other satellite model options. 
 
 

3. DVP DAT Files is a new project import format. Find this in File > Import > DVP DAT Files. Note that DVP PAR 
files can also be imported. SUMMIT EVOLUTION imports the interior orientation values from the DVP project (either 
PAR or DAT) thus it will not make a camera file, will not have a camera file in the project definition, and the 
interior orientation values may not be changed. 

 
 

4. There is a new Use left-handed system setting in the Exterior Orientation (EO) Import Wizard. This was added 
by request of a customer who wanted to import a third-party KLT Atlas EO .dat file format, which used a left-
handed method of processing the omega, phi, and kappa values. All other formats that DAT/EM is aware of are 
right handed and will need this setting OFF. 

 
5. A new GeoCalc Blue Marble database is included in SUMMIT EVOLUTION version 6.2. 

 
6. When importing exterior orientation values, the phi and omega values had trouble if they were expressed as, for 

example, 358.998° rather than -0.002°. This has been fixed to accept any equivalent expression of the angle. 
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7. Status Tracker is a new Project Management tool. It allows you to create a grid of rectangular areas in a 
Microsoft Access mdb database file. You create your own data fields to track whatever information is important to 
you. This is available in PROFESSIONAL and FEATURE COLLECTION Editions only. 
 
Before generating a new database, turn on SUMMIT EVOLUTION Tools > Options > Project > Automatically load 
next model when outside stereo region. This allows the Status Tracker to calculate the project extents. A fully 
oriented project must be open.  
 
Activate it from SUMMIT EVOLUTION Tools menu > Status Tracker or from the Tools toolbar. 
 

 
For further instructions, please see the Summit Evolution Operation Manual version 6.2 or ask DAT/EM Support 
for instructions. 
 

 
8. A  message now appears for aerial projects if you try to close the Project Edit dialog with Earth Curvature 

Correction and/or Refraction Correction on, but Image Scale (Ratio) set to 0 (zero). The only difference is the 
new message; it has always been true that the Image Scale (Ratio) must be set correctly in order to effectively 
apply the corrections. 

 
9. Messages may now appear during coordinate conversion settings. For example, when a 2D coordinate system is 

selected, a message appears, “The system is set to 2D. Would you like to select a 3D point style?” Select Yes to 
select a 3D point style such as “Projected Point in Meters, 3 Dimensions”. The resulting dialog is the same as if 
you had selected the Change Units button: 

 
 

  
Selecting “Yes” is the same as selecting the “Change Units” button 

 
 
A message will also appear if there is more than one geoid choice for the selected system. The resulting dialog 
for a “Yes” answer is the same as if you had selected the Vertical Reference button. 
 
These messages do not represent a change in functionality. They are meant to help and guide you to choose a 
complete combination of settings. 
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10. There is a new option to set a separator character to appear between x, y, and z in the coordinate bar. Find this in 
Tools > Options > Coordinates > Use these separators between coordinates. The current coordinate in the 
coordinate bar may also be copied and/or pasted. As a practical example, set the separator to a comma followed 
by a space character, then copy and paste the coordinate out of the coordinate bar and into a text file. 

 

  
 
 

11. In DiMAC digital camera projects, a fix was made so that it would not automatically load a single image at the end 
of a strip where a whole model was not available. Now when Tools > Options > Project > Automatically load 
next model when outside stereo region is on, only whole models with ground coordinates will be opened 
automatically. 
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12. SUMMIT’s Help > Release Information (Datem Info.exe) now has a button to copy the contents to the Windows 

clipboard. This may be used to help copy and paste the release information into an email to DAT/EM Support. 
 

 
 

13. The following error sequence occurred with multiple viewports: DAT/EM Drawing Objects existed in the active 
viewport; the active viewport was closed; another viewport was automatically assigned to be the new active 
viewport; the DAT/EM Drawing Objects were incorrectly drawn with an offset in the newly assigned active 
viewport. This has been fixed to draw the objects at the correct locations in any new active viewport. 

 
14. Tools > Get 3D Device is a new option for SUMMIT EVOLUTION to quickly take control of the 3D device from 

DAT/EM LANDSCAPE. 
 

15. The 3D Vector Window now shows the same object types that are checked on for the Main View. Previously, it 
would always show all object types. The object type settings are Objects, Points, and Text, which are located on 
the SUMMIT EVOLUTION>Tools>Options>SI tab. 

 
16. EK2000 handwheels is a new input device option in Summit>Tools>Options>Input Devices. 
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17. BUTTON MANAGER has updates and fixes:  
a. On the Stealth tab, there is now an option to show the Stealth SZ-3. If you have this type of input device, 

pay careful attention to the button numbering; the buttons are numbered in a different order from other 
Stealth and Immersion input devices. 

 

 
 

b. If a button configuration was imported or a new button configuration was saved under the same name as an 
existing configuration, except with a different combination of upper and lower case letters in its name, Button 
Manager could crash. For example, it would crash if both “MyButtons” and “MYBUTTONS” existed at the 
same time. This has been fixed so that it is no longer case sensitive. 

c. The BUTTON MANAGER has two new settings that are specific to LANDSCAPE: Snap to Surface and Give up 
3D Mouse. More information is listed below in the LANDSCAPE section. 

 
 

18. IMAGE CREATOR has the following changes: 
a. IMAGE CREATOR and all other DAT/EM software that reads image files have a TIF compatibility enhancement. 

A customer sent us an example of an unusual TIF format that had two embedded images that were not 
image pyramid levels. DAT/EM software expected to find only image pyramid levels in that location. 

b. The settings in IMAGE CREATOR’s “Create various number of bands” dialog will now be saved for the next 
time the dialog is viewed during the same session of IMAGE CREATOR. 
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19. PROJECT VIEWER WITH ORTHOPHOTO AND MOSAIC has changes: 

 
a. The vector import step for orthophoto generation can now save and load the layer checkmark status. This is 

useful when input files for different projects use the same layer/level naming schema. 
 

b. When a VisionMap A3 project was open in both SUMMIT EVOLUTION and PROJECT VIEWER, Move by Pick 
selected in PROJECT VIEWER caused SUMMIT EVOLUTION to move to (x, y, 0). This has been fixed so that 
SUMMIT’s elevation does not change during the move. 

 
c. The mosaicking process now supports full 16-bit image generation. 

 
The input orthophotos must be 16 bit in order to output a 16-bit mosaic. 

 
The Create Mosaic > Image tab > Use JPEG compression setting must be OFF in order to output a 16-bit 
image. If Use JPEG compression is ON, the output image will be 12 bit. This is not a DAT/EM-controllable 
restriction; the JPEG compression standard does not support 16-bit imagery. 

 

 
 

d. The orthophoto generation process can now be set for multithreading. This is generally equivalent to using 
multiple processors, depending on how the operating system delegates its tasks.  
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• Multithreading=1 will generate one orthophoto at a time. Multithreading=2 will generate two 
orthophotos at a time, and so on. The higher the setting, the more memory and computer 
processing resources will be used. 

 
• A “thread” is a path of execution. The operating system (OS) determines which processor a thread 

will use. If a thread is taking a large amount of processing, the OS will send the next thread to the 
next processor. Setting Multithreading=2 is roughly synonymous with processing one orthophoto 
on one processor and another orthophoto on a second processor. However, if the computer is 
already running a processor-intensive application, the OS may send both orthophoto threads to the 
same processor. Thus, overall speed of orthophoto generation is dependent on what other 
applications are currently running. 

 
• Set Multithreading to the maximum number only if orthophoto generation is the only task to be run 

on the computer. Setting the maximum number will make orthophoto processing as fast as possible, 
but it will prevent any other tasks from running at an acceptable speed. 

 
• If Multithreading is set to the maximum number while another resource-intensive application is 

running (such as SUMMIT EVOLUTION, LANDSCAPE, aerotriangulation software, or some antivirus 
scans), the computer could run out of resources and crash. Resources include processors, memory, 
and disk access.  

 
• Never run orthophoto generation in multiple instances of PROJECT VIEWER with Multithreading set 

at the maximum number in any of them. This could cause the computer to run out of resources and 
crash. 

 
e. A problem was fixed that affected loading vector files in the orthophoto procedure’s “Select DTM Files” 

dialog. If multiple files were listed, but one could not be found, none of the files would load. Now all of the 
files that can be found will be loaded. 
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LANDSCAPE 
 

 
 

1. Landscape allows edits on only some types of files: LAS, BIN, SDTM, ASC, BIL, and PIX. Note that ASC, BIL, 
and PIX are grid-only formats so they cannot be edited in XY. (Hint: If a file is not in one of these formats, use the 
Point Translator to convert it to an editable format.) 
 
In previous versions, you could try to edit text files, but since it was not an editable format, LANDSCAPE might 
crash. Now, LANDSCAPE prevents you from trying to edit non-editable file formats. 
 
To help you see whether a file is editable or not, another color has been added to the filename list in the Project 
Window. Gray text means a file is read-only. Hover the system mouse over the filename to receive more 
information. 
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2. LANDSCAPE’s Help > Datem Info (Datem Info.exe) now has a button to copy the contents to the Windows 
clipboard. This may be used to help copy and paste the release information into an email to DAT/EM Support. 

 

 
 
 

3. The Z Bounds display in the Selected Point Properties window is no longer rounded off. For example, in previous 
versions, the following highlighted display would have been Z Bounds 462.000, 492.000. 
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4. The BUTTON MANAGER has two new settings that are specific to LANDSCAPE:  

a. Snap to Surface. This button causes the LANDSCAPE cursor to snap to the elevation of the surface. It 
does not change the (x,y) position. It has the same function as the <Alt>s keyin. 

 

 
 

b. Give up 3D Mouse. This button causes LANDSCAPE to release control of the 3D device. This is usually 
done so that SUMMIT EVOLUTION can gain control of the 3D device.  
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5. Follow Surface is a new tool that makes the z coordinate snap to the z of the surface at all times. This is similar 

to SUMMIT EVOLUTION’s Terrain Following tool. As the cursor moves in (x,y), the z follows the current surface 
elevation. 

 
Follow Surface is located on the View toolbar and the View menu. To the right of the button on the toolbar, there 
is a filter setting menu. The filter allows you to apply a filter to the points that make up the surface to be followed. 
To use all points for the surface, set it to <Select All>. To create new filters, use Tools>LIDAR Filter Editor. 

 

 
 

6. There is a new Landscape without stereo option on the Windows Start menu for the Datem Software group. 
This allows you to start Landscape in mono viewing mode. This is useful when you are also starting SUMMIT 
EVOLUTION, and you would like SUMMIT EVOLUTION to be the primary stereo application. 

 

 
Example of Landscape and Landscape without stereo (shown in Windows 7) 

 
 

DAT/EM CAPTURE for ArcGIS 

 
NOTE: Compatible with 32-bit versions of ArcGIS 9.1, 9.2 and 9.3.1. 
 
There are no changes to the user interface for version 6.2. Work is progressing on compatibility with ArcGIS version 10, 
which should be available in version 6.3. 
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DAT/EM CAPTURE for AutoCAD 

 
 
NOTE: Compatible with 32-bit AutoCAD 2000-2010 versions. 
 Compatible with 64-bit AutoCAD 2008-2011 versions. 
 

1. Polylines with splined parts were not displayed in SUMMIT EVOLUTION superimposition (SI) correctly. The spline 
control points were being used as vector endpoints. This was fixed. 

 
2. Breaklinefilter (standalone command) was not processing polylines that contained splined parts correctly. It was 

using the spline control points incorrectly. This was fixed. 
 

3. The 3DOFFSET tool was fixed to offset splined polylines correctly. These changes apply to all versions of 
AutoCAD. 

 
4. SPOTX has a new option to place an AutoCAD Point. Along with the spot elevation text, it can place a point, a 

block, or both point and block. The point may be placed at the location of the cursor (At Block option) or at the 
location of the text decimal point (At Text Decimal Point option). The Shift Z to nearest setting affects both the 
point and the block. Use SPOTXSET to make settings before using SPOTX. 
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5. DATDRAW has many changes and fixes: 
a. DATDRAW is now available for AutoCAD versions 2004 and higher. 
b. Memory leaks and problems with existing functionality (such as closing) were fixed. 
c. In AutoCAD 2004, ACAD was crashing when the OSNAPs were enabled with DATDRAW streaming. It will now save 

the OSNAP value and disable OSNAPs when stream mode is entered. It will restore the saved OSNAP value when 
stream mode is exited. 

d. SUMMIT EVOLUTION can now zoom during drawing without adding an invalid point to the polyline. 
e. Stream mode digitizing will continue with the digitizer that started the first stream mode point. If SUMMIT 

EVOLUTION starts the digitizing, then the system mouse may not add points; similarly, if the system mouse 
started the digitizing, then SUMMIT EVOLUTION may not add points. This prevents the “wrong” digitizer from 
accidentally adding points to the polyline. 

f. The previous 2D/3D DATDRAW command is automatically reselected if the previous draw was 
terminated by a space bar or return key. 

g. The <Esc> escape key now mimics the behavior of the spacebar key in drawing mode. Pressing <Esc> 
once during digitizing ends the current polyline. The user may then start a new polyline by selecting a 
point. 

h. A new Auto Close option was added to the command line and to the Options dialog. This setting affects 
the squared digitizing mode only. When on, a squared polyline will automatically close when the polyline 
finishes. 

i. A new Undo option was added to the initial DATDRAW command line. This Undo removes the most 
recently completed composite polyline, and may be repeated until the first polyline of the DATDRAW 
session has been removed. This undo is useful to remove individual polylines that were drawn during the 
current DATDRAW session. Note that this differs from the “undo” in the second stage drawing mode, 
which deletes the tail (most recent vertex) of the current composite polyline. It also differs from AutoCAD’s 
own “undo”, which removes all of the polylines that were drawn during the recent DATDRAW session. 

j. A new Auto Join option was added. If a datdraw polyline is started or ended at an end point of an 
existing polyline of the same type (e.g. 2D or 3D polyline), the two polylines are joined.  
• If a datdraw polyline is started and ended on end points of existing polylines, all three lines will be 

joined. (In the case that a datdraw polyline is started on one end point of an existing polyline and 
ended on the other end of the same polyline, the two lines will be joined and the polyline will be 
marked as closed.) 

• Join at both ends behavior can be disabled by selecting the “Auto join” datdraw command line 
option and disabling “Join both ends.” When disabled and a datdraw polyline started and ended on 
end points of existing polylines, the datdraw polyline will be joined with the polyline that shares its 
start point. 

• The auto join functionality can be enabled/disabled through the “Auto join” command line option.  
• Added auto join help to the “?” command line option. 
• By default, “auto join” and “join at both ends” is enabled. 

 



 20

k. A new dialog can help to quickly change the drawing modes and access other settings. At the DATDRAW 
command, enter D to show the dialog. Click the system mouse on the desired 2D polyline or 3D polyline 
setting to start a polyline. Use the point-to-point, square, stream, 2-point arc, and 3-point arc icons to 
change the drawing mode. The drawing mode may be changed without breaking the current polyline; 
however, changing the 2D polyline / 3D polyline setting will force any previous polyline to end and will 
start the new type of polyline.  

 

 
 
The Options button offers the DATDRAW settings in a dialog format. All of the settings in Options can 
be accessed from the DATDRAW command line. Note that at this time, the Options dialog works for 
click-only settings; for key-in entries, please use the DATDRAW command line.  

 
l. An Auto Join option was added. General behavior: 

• If a DATDRAW polyline is started or ended at an end point of an existing polyline of the same type 
(e.g. 2D or 3D polyline), the two polylines are joined.  

• If a DATDRAW polyline is started and ended on end points of existing polylines, all three lines will 
be joined. (In the case that a DATDRAW polyline is started on one end point of an existing polyline 
and ended on the other end of the same polyline, the two lines will be joined and the polyline will be 
marked as closed.) 

• Join at both end behavior can be disabled by selecting the “autoJoin” DATDRAW command line 
option and disabling “Join both ends.” When disabled and a datdraw polyline started and ended on 
end points of existing polylines, the datdraw polyline will be joined with the polyline that shares its 
start point. 

• The auto join functionality can be enabled/disabled through the “autoJoin” command line option. 
• Added auto join help to the “?” command line option. 
• By default, “auto join” and “join at both ends” is enabled. 

 
 
 
 
DAT/EM CAPTURE for MicroStation 

 
Changes apply to Capture for MicroStation V8/2004 Edition, MicroStation XM, and MicroStation V8i Series 1 on 32-bit and 64-
bit operating systems. Note: 

• MicroStation V8 and V8 2004 Edition: Version should be 08.05.00.34 or higher. 
• MicroStation XM and V8i Series 1: XM version should be 08.09.04.88 or higher. CAPTURE and MAP EDITOR will install 

for these versions if they exist on the computer. 
• MicroStation V8i Series 2: DAT/EM software does not install for V8i Series 2 at this time. 

 
 
1. The BreakLineFilter command contains performance enhancements. Processing speed is improved for all cases, but 

especially for complex line strings that have over 5000 vertices. 
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2. The Map/Editor MECLOSE command has additional VISIT file logging options. This could help you find closed line 
strings that are not shapes, for example, and view them before or after editing them. 

 

        
 

• No Logging (Default): By default, results of the MECLOSE command are not logged. The command 
ends when closing finishes. 

 
• Log Edits to X, Y, Z file: Closing is performed and each edit location is written to a file for the VISIT 

command to use. If this option is selected, please specify a unique log file name. After MECLOSE runs 
and it makes the file, it prompts whether to immediately launch the VISIT command. Select yes to run 
VISIT now, or select no to end. Run VISIT later, if desired. 

 
• Log Potential Edits to X, Y, Z file: Closing is not performed right away. Potential edit locations are found 

and written to a file for the VISIT command to use. If this option is selected, please specify a unique log 
file name. After MECLOSE runs and it makes the file, it prompts whether to immediately launch the VISIT 
command. Select yes to run VISIT now, or select no to end. Run VISIT later, if desired. VISIT moves the 
cursor to each potential edit location and draws a marking circle around the object’s common endpoints. If 
desired, another command such as LCLOSE may be used to convert the element to a shape, then move 
on to the next VISIT coordinate.  
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3. DTM CALCULATE can now process complex shapes as boundary elements. 
 
4. MEWEED (Map/Editor’s Weed Contours) has two changes: 

a. In addition to the existing option to delete processed elements, it now offers options to change attributes. 
b. It can now find line strings and shapes whose areas are below a set minimum area. This is useful to remove 

contour isolations (tiny closed contours) made by third-party automatic contour generation software or if you 
forgot to use the Minimum Area setting in DAT/EM’s CONTOUR CREATOR. MEWEED will assume a line string is 
closed and find the area of the line string as if it had snapped endpoints. 

 

 
 
 
5. XYPARTIAL and XYZPARTIAL were fixed. Previously, they could create jagged line strings, an extra visual 

highlighted point could occur during use, and selection of the first vertex could result in a corrupt element or simply the 
incorrect elevation. 

 
6. PSQR can now be run immediately after DATDRAW. Previously, MicroStation would crash if the commands were 

used in this order. 
 
7. BREAKLINEFILTER now has some performance enhancements (it will run much faster!) and additional error 

checking to prevent crashes and/or processing incorrect elements. 
 
8. REVERSELINE’s arrow has been corrected to be aligned better with the object it is marking.  
 
9. Work has started on making the 3D tentative hint appear in XM and V8i. Although the tentative hint has worked for 

years in MicroStation V8, we found that it became partially obscured around the cursor in XM and V8i. A new method 
has been implemented to produce the text. Now the 3D tentative hint will appear. This was a last-minute addition to 
6.2; in the next version, there will be more settings to control the placement, angle, and size of the text. Please be 
patient while we complete these changes. 

 
Best results will be seen with the 3D tentative hint in SUMMIT EVOLUTION’s main view when MicroStation’s SI 
SETTINGS>Tentative On setting is checked ON. 

 
10. MEFIXCOMPLEX (Map/Editor’s Fix Complex Element) will now reduce complex shapes into simple shapes if 

possible. For example, a complex shape made of two five-vertex line strings will be reduced to a simple type 6 shape. 
It also had a problem running with selected elements (rather than classes or selection sets), and this has been fixed. 

 
11. MECHANGEINTERIOR (Map/Editor’s Change Attributes Interior) can now process boundaries that exceed 5000 

vertices. 
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12. JOINIT and MEJOINIT have the following changes: 
a. They would sometimes only perform a join on one end of a line string, despite the fact that a join condition 

existed at both ends of the line string. This has been fixed. 
b. The Condense Levels checkbox has been replaced with new options: Master, Master + Attachments, and 

Attachments Only. This addresses the need to be able to “touch to” elements with like symbology in the 
master file only, the master file and reference files, or reference files only. 

 
o Master only disregards attached models and operates strictly on elements in the master design. 

Elements in the “Touch To” set are still treated as references and are not modified. 
o Master + Attachments was previously named “Condense Levels”. This option processes all 

elements in the “Touch to Set” in all open designs (Master and Attachments). If an element is in the 
Modify Set and the “Touch To” set, the ambiguity is resolved by treating the element as a “Touch 
To” element. This is used when symbology is used exclusively for reference elements, independent 
of where the elements reside.  

o Attachments only considers only reference elements (in Attached models) as “Touch To” 
elements. Master elements are ignored and may be included in the Modify set. 

 

 
 
13. MECLOSE (Map/Editor’s Close Line String) has new logging options and can create a file for the VISIT command. 
 
14. Some commands, such as EZEDIT, BREAKLINEFILTER, and BUILDINGFRAME could have problems with 

temporarily turning a selected object’s level to white in the Level Manager. This has been fixed. 
 
15. MEFINDDUPLICATES (Map/Editor’s Find Duplicates) has some fixes for XM and V8i. It now draws the temporary box 

that surrounds the duplicate elements, and a potential crash was fixed. 
 
16. MECHANGETEXT (Map/Editor’s Change Text) has been fixed to correctly apply a new font. 
 
17. MicroStation startup time was affected on computers that had DAT/EM Capture installed, but were not currently 

loading the DAT/EM capture<version>.ma file. This has been fixed so that MicroStation does not start slowly when 
not loading Capture. 
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18. MESCALLOP for XM and V8i has been improved for running from a parameter file. These changes especially help in 
setting the “reverse side” direction for scallop. 

 
19. ROAD and ROADLOADFILE have several fixes. The dialog settings are now written correctly to the registry with 

MicroStation XM and Windows 7. The “Run” button timing problems have been fixed, so that it will not run with older 
settings instead of the current settings. 

 
20. The following commands have a fix to properly map the font name: LD CP, GRIDIT, ZLABEL, LABELIT, CHCELL, SI 

Bounds, and MECHANGETEXT. 
 
21. ELINE NEAREST Z has several improvements to error handling so that it will complete correctly in more special 

cases. 
 
22. The following commands have a fix to properly erase their temporary fence: EZEDIT, ZLABEL, and JOINIT. 
 
23. The DATDRAW CHANGE, DATDRAW CHANGE SETTINGS, DATDRAW CHANGE OFF key-ins have been 

removed. They did not function well, and were generally not needed or used. 
 
24. The DTM CALCULATE SELECT dialog has been fixed so that it will not crash in XM and V8i. 
 
25. EZEDIT has many changes. Previously, this command supported arc editing only. As of 6.2, interactive editing of 

linear and complex elements are incorporated along with vertex display enhancements. EZEdit operates in three 
modes: Operations on whole elements, operations on individual vertices, and a “display only” mode where vertices 
are marked while other commands may be used. These are described below. 

 
a. Vertex and Direction Marking: In Vertices and Display only modes, the Display Settings button activates 

a dialog to set vertex and direction arrow marking options. Elements in the Display Settings>Display>Set 
selection set will be marked. Elements in reference files are not editable and are not marked. 

 

 
To mark all elements, select Sets and make a selection 

set with everything in it. To restrict marking to certain 
elements, make a more restrictive selection set. 



 25

b. Whole Element Mode: The Whole Element setting offers editing commands that affect the entire element. 
The commands are Clip (like Delete Partial), Set Elevation (change elevation of whole element), and 
Reverse (reverse vertex order). 

 

 
Whole Element > Clip works like Delete Partial. 

 

 
Whole Element>Reverse reverses the vertex order. 
Select the element to reverse, then select Apply. This 
command automatically displays editable element 
directions within the active view. Reference elements 
can not be edited so direction is not shown. 

 

 
Whole Element>Set Elevation sets all the vertices in 
the element to a constant value. Select the element, key 
in a new Z or select CurrentZ to fetch MicroStation’s 
active elevation (or stereoplotter Z), then select Apply. 
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c. Vertices Mode: The Vertices setting offers editing commands that affect individual vertices. The commands 
are Delete, Move, and Insert. 

 

 
Vertices>Delete deletes a selected vertex. Select and accept the vertex. 

 

 
Vertices>Move moves a vertex. Make settings: Fix Z sets the Z 
value if checked on; original Z retained if off. XY Fixed keeps the 
same XY value if on; allows the XY to change if off. Enable 
Snaps turns on snaps automatically if on. Select the element, 
accept the element, select the new location, accept the new 
location. 
 
The original arc editing functionality is still supported in the 
Vertices>Move mode. In addition, enhanced functionality to fix 
or interpolate Z, fix XY (moving only Z) or applying snaps has 
been added to EZEDIT ARC editing. 
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Vertices>Insert adds a vertex. Make settings: Fix Z sets the Z 
value if checked on; Interpolate Z is the alternative, which 
interpolates the elevation along the existing segment. XY Fixed 
keeps the first-selected XY point if on. Enable Snaps turns on 
snaps automatically if on. Select the element, accept the 
element, select the new vertex location, accept the new vertex 
location. 

 
 

d. EZEDIT>Undo: The Undo button can undo individual EZEDIT edits back to the first edit of the current 
EZEDIT session. By comparison, MicroStation’s standard UNDO might undo every edit performed in the 
recent EZEDIT session. 


